Summer Certification Limited Time 70% Discount Offer - Ends in 0d 00h 00m 00s - Coupon code: cramtick70

SPLK-1002 Splunk Core Certified Power User Exam Questions and Answers

Questions 4

In most large Splunk environments, what is the most efficient command that can be used to group events by fields/

Options:

A.

join

B.

stats

C.

streamstats

D.

transaction

Buy Now
Questions 5

Which of the following definitions describes a macro named "samplemacro" that accepts two arguments?

Options:

A.

samplemacro[2]

B.

samplemacro[1,2]

C.

samplemacro(2)

D.

samplemacro(1,2)

Buy Now
Questions 6

Which of the following commands connects an additional table of data directly to the right side of the existing table?

Options:

A.

subsearch

B.

update

C.

appendcols

D.

append

Buy Now
Questions 7

Which of these is NOT a field that is automatically created with the transaction command?

Options:

A.

maxcount

B.

duration

C.

eventcount

Buy Now
Questions 8

The Splunk Common Information Model (CIM) is a collection of what type of knowledge object?

Options:

A.

KV Store

B.

Lookups

C.

Saved searches

D.

Data models

Buy Now
Questions 9

Which of the following options will define the first event in a transaction?

Options:

A.

startswith

B.

with

C.

startingwith

D.

firstevent

Buy Now
Questions 10

When used with the timechart command, which value of the limit argument returns all values?

Options:

A.

limit=*

B.

limit=all

C.

limit=none

D.

limit=0

Buy Now
Questions 11

Complete the search, …. | _____ failure > successes

Options:

A.

Search

B.

Where

C.

If

D.

Any of the above

Buy Now
Questions 12

Which of the following is one of the pre-configured data models included in the Splunk Common Information Model (CIM) add-on?

Options:

A.

Access

B.

Accounting

C.

Authorization

D.

Authentication

Buy Now
Questions 13

When a search returns __________, you can view the results as a list.

Options:

A.

a list of events

B.

transactions

C.

statistical values

Buy Now
Questions 14

Which workflow uses field values to perform a secondary search?

Options:

A.

POST

B.

Action

C.

Search

D.

Sub-Search

Buy Now
Questions 15

When using the transaction command, how are evicted transactions identified?

Options:

A.

Closed_txn field is set to o, or false.

B.

Max_txn field is set to O, or false.

C.

Txn_field is set to 1, or true.

D.

open_txn field is set to 1, or true.

Buy Now
Questions 16

Which option of the transaction command would be used to specify the maximum time between events in a transaction?

Options:

A.

maxpause

B.

maxspan

C.

duration

D.

 eventcount

Buy Now
Questions 17

What do events in a transaction have In common?

Options:

A.

All events In a transaction must have the same timestamp.

B.

All events in a transaction must have the same sourcetype.

C.

All events in a transaction must have the exact same set of fields.

D.

All events in a transaction must be related by one or more fields.

Buy Now
Questions 18

Which type of visualization shows relationships between discrete values in three dimensions?

Options:

A.

Pie chart

B.

Line chart

C.

Bubble chart

D.

Scatter chart

Buy Now
Questions 19

What happens to the original field name when a field alias is created?

Options:

A.

The original field name is not affected by the creation of a field alias.

B.

The original field name is replaced by the field alias within the index.

C.

The original field name is italicized to indicate that it is not an alias.

D.

The original field name still exists in the index but is not visible to the user at search time.

Buy Now
Questions 20

When using the Field Extractor (FX) to perform a field extraction, which delimiter can be used?

Options:

A.

A period or comma.

B.

A comma.

C.

A tab or space.

D.

Any consistent character.

Buy Now
Questions 21

Use the dedup command to _____.

Options:

A.

Rename a field in the index

B.

remove duplicate values

C.

provide an additional alias for the field that can D.be used in the search criteria

Buy Now
Questions 22

Which are valid ways to create an event type? (select all that apply)

Options:

A.

By using the searchtypes command in the search bar.

B.

By editing the event_type stanza in the props.conf file.

C.

By going to the Settings menu and clicking Event Types > New.

D.

By selecting an event in search results and clicking Event Actions > Build Event Type.

Buy Now
Questions 23

We can use the rename command to _____ (Select all that apply.)

Options:

A.

Change indexed fields

B.

Exclude fields from our search results

C.

Extract new fields from our data using regular expressions

D.

Give a field a new name at search time

Buy Now
Questions 24

To which of the following can a field alias be applied?

Options:

A.

Data found in a lookup table.

B.

Either a calculated field or an extracted field.

C.

Only one single field in a dataset.

D.

A given host, source, or sourcetype.

Buy Now
Questions 25

A calculated field may be based on which of the following?

Options:

A.

Fields generated within a search string

B.

Lookup tables

C.

Regular expressions

D.

Extracted fields

Buy Now
Questions 26

When using a field value variable with a Workflow Action, which punctuation mark will escape the data

Options:

A.

*

B.

!

C.

^

D.

#

Buy Now
Questions 27

What type of command is eval?

Options:

A.

Streaming in some modes

B.

Report generating

C.

Distributable streaming

D.

Centralized streaming

Buy Now
Questions 28

Which of the following about reports is/are true?

Options:

A.

Reports are knowledge objects.

B.

Reports can be scheduled.

C.

Reports can run a script.

D.

All of the above.

Buy Now
Questions 29

Which of the following can be saved as an event type?

Options:

A.

index=server_539 sourcetype=BETA_713 code=439 | stats count by code

B.

index=server_539 sourcetype=BETA_713 code=439 | where code > 200

C.

index=server_539 sourcetype=BETA_713 code=439 [ | inputlookup servercode.csv append=t ]

D.

index=server_539 sourcetype=BETA_713 code=439

Buy Now
Questions 30

Two separate results tables are being combined using the |join command. The outer table has the following values:

Refer to following Tables

The line of SPL used to join the tables is: | join employeeNumber type=outer

How many rows are returned in the new table?

Options:

A.

Zero

B.

Five

C.

Eight

D.

Three

Buy Now
Questions 31

Which of the following fields should be normalized using the Splunk Common Information Model (CIM) based on their relationship?

Options:

A.

src_ip, dest_ip

B.

src_ip, source_ip

C.

index, sourcetype

D.

src_ip, src_port

Buy Now
Questions 32

This function of the stats command allows you to identify the number of values a field has.

Options:

A.

max

B.

distinct_count

C.

fields

D.

count

Buy Now
Questions 33

Which of the following knowledge objects can reference field aliases?

Options:

A.

Calculated fields, lookups, event types, and tags.

B.

Calculated fields and tags only.

C.

Calculated fields and event types only.

D.

Calculated fields, lookups, event types, and extracted fields.

Buy Now
Questions 34

When using transaction, what is the default maximum span between events?

Options:

A.

Unlimited

B.

1h

C.

1m

D.

1d

Buy Now
Questions 35

Using the Field Extractor (FX) tool, a value is highlighted to extract and give a name to a new field. Splunk has not successfully extracted that value from all appropriate events. What steps can be taken so Splunk successfully extracts the value from all appropriate events? (select all that apply)

Options:

A.

Select an additional sample event with the Field Extractor (FX) and highlight the missing value in the event.

B.

Re-ingest the data and attempt to extract from a new dataset.

C.

Click on the event where the field was not extracted and choose “Change to Delimited".

D.

Edit the regular expression manually.

Buy Now
Questions 36

Which of the following commands support the same set of functions?

Options:

A.

stats, eval, table

B.

search, where, eval

C.

stats, chart, timechart

D.

transaction, chart, timechart

Buy Now
Questions 37

What does the fillnull command replace null values with, if the value argument is not specified?

Options:

A.

0

B.

N/A

C.

NaN

D.

NULL

Buy Now
Questions 38

What does the fillnull command replace null values with, it the value argument is not specified?

Options:

A.

0

B.

N/A

C.

NaN

D.

NULL

Buy Now
Questions 39

Which of the following examples would use a POST workflow action?

Options:

A.

Perform an external IP lookup based on a domain value found in events.

B.

Use the field values in an HTTP error event to create a new ticket in an external system.

C.

Launch secondary Splunk searches that use one or more field values from selected events.

D.

Open a web browser to look up an HTTP status code.

Buy Now
Questions 40

Why would the following search produce multiple transactions instead of one?

Options:

A.

The maxspan option is not included.

B.

The transaction command has a limit of 1000 events per transaction.

C.

The transaction and commands cannot be used together.

D.

The stats list () function is used.

Buy Now
Questions 41

Given the following eval statement:

...| eval fieldl - if(isnotnull(fieldl),fieldl,0), field2 = if(isnull < field2 > , "NO-VALUE", fieid2)

Which of the following is the equivalent using f ilinull?

Options:

A.

There is no equivalent expression using f ilinull

B.

... t filinull values=(0,"NO-VALUE") fields=(fieldl,field2)

C.

... I filinull value=0 fieldl I fillnull fields

D.

... I fillnull fieldl I filinull value="NO-VALUE" field2

Buy Now
Questions 42

Which of the following are valid options to speed up reports? (Select all the apply.)

Options:

A.

Edit permissions

B.

Edit description

C.

Edit acceleration

D.

Edit schedule

Buy Now
Questions 43

Which of the following statements describes the command below (select all that apply)

Sourcetype=access_combined | transaction JSESSIONID

Options:

A.

An additional filed named maxspan is created.

B.

An additional field named duration is created.

C.

An additional field named eventcount is created.

D.

Events with the same JSESSIONID will be grouped together into a single event.

Buy Now
Questions 44

The stats command will create a _____________ by default.

Options:

A.

Table

B.

Report

C.

Pie chart

Buy Now
Questions 45

Which of the following statements describes POST workflow actions?

Options:

A.

POST workflow actions are always encrypted.

B.

POST workflow actions cannot use field values in their URI.

C.

POST workflow actions cannot be created on custom sourcetypes.

D.

POST workflow actions can open a web page in either the same window or a new .

Buy Now
Questions 46

When using | timechart by host, which field is represented in the x-axis?

Options:

A.

date

B.

host

C.

time

D.

_time

Buy Now
Questions 47

During the validation step of the Field Extractor workflow:

Select your answer.

Options:

A.

You can remove values that aren't a match for the field you want to define

B.

You can validate where the data originated from

C.

You cannot modify the field extraction

Buy Now
Questions 48

Which of the following statements about tags is true?

Options:

A.

Tags are case insensitive.

B.

Tags are created at index time.

C.

Tags can make your data more understandable.

D.

Tags are searched by using the syntax tag: : < fieldneme >

Buy Now
Questions 49

Which statement is true?

Options:

A.

Pivot is used for creating datasets.

B.

Data models are randomly structured datasets.

C.

Pivot is used for creating reports and dashboards.

D.

In most cases, each Splunk user will create their own data model.

Buy Now
Questions 50

Which of the following options should a user add to a search to limit transactions to a five minute time window?

Options:

A.

duration=5m

B.

bin=5m

C.

earliest=-5m

D.

maxspan=5m

Buy Now
Questions 51

Consider the following search:

Index=web sourcetype=access_combined

The log shows several events that share the same JSESSIONID value (SD404K289O2F151). View the events as a group. From the following list, which search groups events by JSESSIONID?

Options:

A.

index=web sourcetype=access_combined SD404K289O2F151 I table JSESSIONID

B.

index=web sourcetype=access_combined JSESSIONID < SD404K289O2F151 >

C.

index=web sourcetype=access_combined I highlight JSESSIONID I search SD404K289O2F151

D.

index-web sourcetype=access_combined I transaction JSESSIONID I search SD404K289O2F151

Buy Now
Questions 52

The fields sidebar does not show________. (Select all that apply.)

Options:

A.

interesting fields

B.

selected fields

C.

all extracted fields

Buy Now
Questions 53

Based on the macro definition shown below, what is the correct way to execute the macro in a search string?

Options:

A.

Convert_sales (euro, €, 79)”

B.

Convert_sales (euro, €, .79)

C.

Convert_sales ($euro,$€$,s79$

D.

Convert_sales ($euro, $€$,S,79$)

Buy Now
Questions 54

What are the expected results for a search that contains the command | where A=B?

Options:

A.

Events that contain the string value where A=B.

B.

Events that contain the string value A=B.

C.

Events where values of field are equal to values of field B.

D.

Events where field A contains the string value B.

Buy Now
Questions 55

Which of the following is true about data model attributes?

Options:

A.

They cannot be created within the data model.

B.

They can only be added into a root search dataset.

C.

They cannot be edited if inherited from a parent dataset.

D.

They can be added to a dataset from search time field extractions.

Buy Now
Questions 56

Which of the following statements describe the search string below?

| datamodel Application_State All_Application_State search

Options:

A.

Evenrches would return a report of sales by state.

B.

Events will be returned from the data model named Application_State.

C.

Events will be returned from the data model named All_Application_state.

D.

No events will be returned because the pipe should occur after the datamodel command

Buy Now
Questions 57

Two separate results tables are being combined using the join command. The outer table has the following values:

The inner table has the following values:

The line of SPL used to join the tables is: join employeeNumber type=outer

How many rows are returned in the new table?

Options:

A.

Three

B.

Eight

C.

Five

D.

Zero

Buy Now
Questions 58

What are the names of the top-level datasets in data models?

Options:

A.

Core datasets

B.

Root datasets

C.

Root indexes

D.

Core indexes

Buy Now
Questions 59

The gauge command:

Options:

A.

creates a single-value visualization

B.

allows you to set colored ranges for a single-value visualization

C.

creates a radial gauge visualization

Buy Now
Questions 60

Which of the following statements describe the Common Information Model (CIM)? (select all that apply)

Options:

A.

CIM is a methodology for normalizing data.

B.

CIM can correlate data from different sources.

C.

The Knowledge Manager uses the CIM to create knowledge objects.

D.

CIM is an app that can coexist with other apps on a single Splunk deployment.

Buy Now
Questions 61

Which of the following is included with the Common Information Model (CIM) add-on?

Options:

A.

Search macros

B.

Event category tags

C.

Workflow actions

D.

tsidx files

Buy Now
Questions 62

Which field extraction method should be selected for comma-separated data?

Options:

A.

Regular expression

B.

Delimiters

C.

eval expression

D.

table extraction

Buy Now
Questions 63

To identify all of the contributing events within a transaction that contains at least one REJECT event, which syntax is correct?

Options:

A.

Index-main | REJECT trans sessionid

B.

Index-main | transaction sessionid | search REJECT

C.

Index=main | transaction sessionid | whose transaction=reject

D.

Index=main | transaction sessionid | where transaction=reject’’

Buy Now
Questions 64

Which of the following statements is true, especially in large environments?

Options:

A.

Use the scats command when you next to group events by two or more fields.

B.

The stats command is faster and more efficient than the transaction command

C.

The transaction command is faster and more efficient than the stats command.

D.

Use the transaction command when you want to see the results of a calculation.

Buy Now
Questions 65

In the Field Extractor, when would the regular expression method be used?

Options:

A.

When events contain JSON data.

B.

When events contain comma-separated data.

C.

When events contain unstructured data.

D.

When events contain table-based data.

Buy Now
Questions 66

Which of the following statements are true for this search? (Select all that apply.) SEARCH: sourcetype=access* |fields action productld status

Options:

A.

is looking for all events that include the search terms: fields AND action AND productld AND status

B.

users the table command to improve performance

C.

limits the fields are extracted

D.

returns a table with 3 columns

Buy Now
Questions 67

How are arguments defined within the macro search string?

Options:

A.

Şarg$

B.

'arg'

C.

%arg%

D.

"arg"

Buy Now
Questions 68

Consider the following search:

index=web sourcetype=access_combined

The log shows several events that share the same JSESSIONID value (SD470K92802F117). View the events as a group.

From the following list, which search groups events by JSESSIONID?

Options:

A.

index=web sourcetype=access_combined | highlight JSESSIONID | search SD470K92802F117

B.

index=web sourcetype=access_combined | transaction JSESSIONID | search SD470K92802F117

C.

index=web sourcetype=access_combined SD470K92802F117 | table JSESSIONID

D.

index=web sourcetype=access_combined JSESSIONID < SD470K92802F117 >

Buy Now
Questions 69

Which of the following is NOT a stats function:

Options:

A.

sum

B.

addtotals

C.

count

D.

avg

Buy Now
Questions 70

Which of the following statements describe the search below? (select all that apply)

Index=main I transaction clientip host maxspan=30s maxpause=5s

Options:

A.

Events in the transaction occurred within 5 seconds.

B.

It groups events that share the same clientip and host.

C.

The first and last events are no more than 5 seconds apart.

D.

The first and last events are no more than 30 seconds apart.

Buy Now
Questions 71

Why are tags useful in Splunk?

Options:

A.

Tags look for less specific data.

B.

Tags visualize data with graphs and charts.

C.

Tags group related data together.

D.

Tags add fields to the raw event data.

Buy Now
Questions 72

These kinds of charts represent a series in a single bar with multiple sections

Options:

A.

Multi-Series

B.

Split-Series

C.

Omit nulls

D.

Stacked

Buy Now
Questions 73

Given the macro definition below, what should be entered into the Name and Arguments fileds to correctly configured the macro?

Options:

A.

The macro name is sessiontracker and the arguments are action, JESSIONID.

B.

The macro name is sessiontracker(2) and the arguments are action, JESSIONID.

C.

The macro name is sessiontracker and the arguments are $action$, $JESSIONID$.

D.

The macro name is sessiontracker(2) and the Arguments are $action$, $JESSIONID$.

Buy Now
Questions 74

A search contains example(100,200). What is the name of the macro?

Options:

A.

example(2)

B.

example(var1,var2)

C.

example($,$)

D.

example[2]

Buy Now
Questions 75

By default, how is acceleration configured in the Splunk Common Information Model (CIM) add-on?

Options:

A.

Turned off

B.

Turned on

C.

Determined automatically based on the sourcetype.

D.

Determined automatically based on the data source.

Buy Now
Questions 76

What is the purpose of the fillnull command?

Options:

A.

Replace empty values with a specified value.

B.

Create a new field based on the values in an existing field.

C.

Rename a specific field in the search results.

D.

Replace all values in a specific field with a default value.

Buy Now
Questions 77

When defining a macro, what are the required elements?

Options:

A.

Name and arguments.

B.

Name and a validation error message.

C.

Name and definition.

D.

Definition and arguments.

Buy Now
Questions 78

What is the correct syntax to find events associated with a tag?

Options:

A.

tag: < field > = < value >

B.

tags= < value >

C.

tags: < field > = < value >

D.

tag= < value >

Buy Now
Questions 79

Which of the following statements describes field aliases?

Options:

A.

Field alias names replace the original field name.

B.

Field aliases can be used in lookup file definitions.

C.

Field aliases only normalize data across sources and sourcetypes.

D.

Field alias names are not case sensitive when used as part of a search.

Buy Now
Questions 80

A space is an implied _____ in a search string.

Options:

A.

OR

B.

AND

C.

()

D.

NOT

Buy Now
Questions 81

What will you learn from the results of the following search?

sourcetype=cisco_esa | transaction mid, dcid, icid | timechart avg(duration)

Options:

A.

The average time elapsed during each transaction for all transactions

B.

The average time for each event within each transaction

C.

The average time between each transaction

Buy Now
Questions 82

Which of the following transforming commands can be used with transactions?

Options:

A.

chart, timechart, stats, eventstats

B.

chart, timechart, stats, diff

C.

chart, timeehart, datamodel, pivot

D.

chart, timecha:t, stats, pivot

Buy Now
Questions 83

Which of the following eval commands will provide a new value for host from src if it exists?

Options:

A.

| eval host = if (isnu11 (src), src, host)

B.

| eval host = if (NOT src = host, src, host)

C.

| eval host = if (src = host, src, host)

D.

| eval host = if (isnotnull (src), src, host)

Buy Now
Questions 84

What does the fillnull command do in this search?

index=main sourcetype=http:log | fillnull value="Unknown"

Options:

A.

Set the values of the field to null when it is "Unknown".

B.

Set all fields that are null to "Unknown".

C.

Set the values of the field to "Unknown" if it is null.

D.

Set all fields with the value of "Unknown" to null.

Buy Now
Questions 85

When using | timchart by host, which filed is representted in the x-axis?

Options:

A.

date

B.

host

C.

time

D.

-time

Buy Now
Questions 86

Which of the following statements describes this search?

sourcetype=access_combined I transaction JSESSIONID | timechart avg (duration)

Options:

A.

This is a valid search and will display a timechart of the average duration, of each transaction event.

B.

This is a valid search and will display a stats table showing the maximum pause among transactions.

C.

No results will be returned because the transaction command must include the startswith and endswith options.

D.

No results will be returned because the transaction command must be the last command used in the search pipeline.

Buy Now
Questions 87

When creating a data model, which root dataset requires at least one constraint?

Options:

A.

Root transaction dataset

B.

Root event dataset

C.

Root child dataset

D.

Root search dataset

Buy Now
Questions 88

When creating an event type, which is allowed in the search string?

Options:

A.

Tags

B.

Joins

C.

Subsearches

D.

Pipes

Buy Now
Questions 89

When using timechart, how many fields can be listed after a by clause?

Options:

A.

because timechart doesn't support using a by clause.

B.

because _time is already implied as the x-axis.

C.

because one field would represent the x-axis and the other would represent the y-axis.

D.

There is no limit specific to timechart.

Buy Now
Questions 90

What is the correct Boolean order of evaluation for the where command from first to last?

Options:

A.

NOT, Parentheses, OR, AND

B.

AND, Parentheses, NOT, OR

C.

Parentheses, NOT, AND, OR

D.

Parentheses, NOT, OR, AND

Buy Now
Questions 91

What information must be included when using the datamodel command?

Options:

A.

status field

B.

Multiple indexes

C.

Data model field name.

D.

Data model dataset name.

Buy Now
Questions 92

There are several ways to access the field extractor. Which option automatically identifies data type, source type, and sample event?

Options:

A.

Event Actions > Extract Fields

B.

Fields sidebar > Extract New Field

C.

Settings > Field Extractions > New Field Extraction

D.

Settings > Field Extractions > Open Field Extraction

Buy Now
Questions 93

What are the two parts of a root event dataset?

Options:

A.

Fields and variables.

B.

Fields and attributes.

C.

Constraints and fields.

D.

Constraints and lookups.

Buy Now
Exam Code: SPLK-1002
Exam Name: Splunk Core Certified Power User Exam
Last Update: Jul 15, 2026
Questions: 306
SPLK-1002 pdf

SPLK-1002 PDF

$25.5  $84.99
SPLK-1002 Engine

SPLK-1002 Testing Engine

$30  $99.99
SPLK-1002 PDF + Engine

SPLK-1002 PDF + Testing Engine

$40.5  $134.99